Tuesday, May 31, 2011

Extruder assembled... more testing!

I got the extruder fully assembled, attaching the hot-end to the cold and clamping it all to a static location. I then connected the extruder motor and hot-end to the Gen6 electronics and launched RepSnapper. I knew from hand feeding 3mm PLA filament through the hot-end that it would melt it fine, and from my temperature testing I now knew it could sustain temperatures on the hot-end and not get hot up along the feeder tube once the little 25mm fan was on. It was still interesting to see what might happen once I asked RepSnapper to "Run Extruder"! I made some little video-clips of the special occasion! :-)








This has been great progress. You will notice the extruding filament may seem a bit thick. I've a 1mm hole in the current nozzle, but now that I have it running in a very basic fashion, I'll swap it out for a .5mm nozzle and see how that goes. The extrusion tests in the video are with a RepSnapper manual "Run Extruder" settings of Speed=2000 and Length = 780. These are completely arbitrary units of measure I'm sure, as there are so many other factors at play here, i.e. gearing ratios, the nozzle hole diam. I'm going to have to do a bit more reading now that I have an extruder to test and calibrate! :-)

Thanks for viewing!

Tuesday, May 24, 2011

New heater block... new tests!

I made a new heater block. During the previous experments I concluded that my heat block was probably too large and impacting on 'time to target temperature'. I cut the new heater block from some aluminium square bar, working to dimensions from a more established design, and  managed to successfully transplanted the thermistor and resistor from the old block.

As others have pointed out, it's easily made, if you drill the holes in the block before cutting the final width, in this case 10mm wide.  You can see the newly cut block below beside my original first-go heater block. 

My previous hot-end had the feeder pipe and nozzle threads of equal length, but given the aluminium is much more heat-conductive I thought I'd make the nozzle thread longer, presenting more heat to the melting chamber area. The new nozzle was simply cut, threaded and drilled from some 6mm aluminium rod, keeping the materials the same. There was no question of using one piece of SS straight through. The stainless steel feeder tube was by choice because of it's lower heat conductivity (see here for comparative conductivities), a key part of this design experiment. But anyway, there was no way I would have been able to drill a small hole in the top given the challenge I had drilling a 3.5mm hole in it. Slow drill speed and lots of pressure with a good feed rate was the trick to drilling stainless steel.

I had wrapped the resistor in tinfoil and bedded the thermistor in some PTFE tape so they were easily recovered from the old heater block. I was interested to see how it survived it's regular toasting. Here it is...just after removal.



I refitted them to the new heater block, secured them with some high-temperature silicone, then mounted the assembled heater block back on the aluminium heat-sink ready for some heat testing!

The keen observers may notice I've removed some fins from the heat-sink. I figured it was way too efficient so we'll see how it works now! I also want a short feeder distance, with a quick transition from cool to hot.

The tests: I connected the hot-end back up to the Gen6 board, and plugged in my laptop, launching RepSnapper. I did two basic tests, manually logging the temperature every 10sec as the new rig was set the task of heating to a target temperature of 200Deg C, i) without the little cooling fan on the heat-sink, and ii) with the fan on. The fan was a 25mm/1" 12v fan. Here are the results...


Observations:
The new heater block is a complete success, in terms of reducing heating times, exceeding 150Deg C in under 2min, whereas the old block took more than 5min to reach the same temperature!

The temperature rose more quickly in the 'fan off' test, and stabilised more closely to the target temperature, maintaining about a 3deg higher stable temperature than the 'fan on' test.

The 'fan on' test took about 2min longer to reach it's max stable temperature.

The target temperature in both tests was never reached in the 'actual' temperature display in RepSnapper. The heater-on green light would flicker from time to time as it approached the target temp (200DegC).

Observations surrounding heat transfer to the aluminium vained heat-sink... 
In the 'fan off' test the heat sink warmed up after a few minutes, and eventually reached a temperature at which it was uncomfortable to touch (that's as scientific as I can measure it at the moment! :-) ).
In the 'fan on' test the heat sink remained cool for a good while and eventually reached a touch warm temperature.

Conclusions:
A combination of reduced heater block size and reduced heat-loss through the feeder tube, by using a less conductive material (stainless steel) has brought the 'heat to target temperature' time in to an user acceptable range. (heater block and nozzle are still aluminium.)
The use of a cooling fan on the heat-sink is essential to maintain a cool filament feeder tube (in this design). Remember, a cool feeder tube stops the filament softening and potentially swelling and jamming in the feeder tube, and in extreme cases of upward heat creep, deforming under the pressure of the idle bearing against the feeder spindle. Cold rigid filament gives a good piston effect on the molten plastic in the melt zone and gives good retraction when reversing.

The use of a cooing fan on the heat-sink from the time you turn on the heater is counter productive, and simply reduces the 'time to target temperature' unnecessarly. A better design would be some kind of simple temperature feedback loop from the heat-sink to the cooling fan, turning it on only as the temperature in the heat-sink began to rise. My setup right now is either 'fan on' when heater on, or fan not on at all.

Final conclusion for today is that the stainless steel feeder tube on it's own offers a very rigid and stable method of supporting the heater block and extruder nozzle, no other supports or supporting materials required. While I haven't conducted full extruder/printing tests, initial impressions of the rigidity of this structure are very positive.

Here's another photo from the rear of the heat-sink where you can observe how the stainless feeder tube is clamped in place and passes through the heat-sink vanes.


Thanks for viewing!





Sunday, May 15, 2011

Extruder heater with stainless steel tube...

I wanted to quickly test Nophead's comment in the previous post, that a stainless steel feeder tube to the heater might result in less heat conductivity away from the heater block, allowing the block to more easily reach a desired target temperature. This, as he suggests might be more successful due to stainless steel being a poorer conductor of heat than aluminium.

To test I took a 6mm stainless 'bolt'. It's actually another leftover element of the salvaged bearings from an old set of Rollerblades. I cut one end off and threaded it (M6 die), removed the aluminium tube and fitted the stainless one.

I then inserted the new tube into the heatsink passing through three vanes, giving sufficient contact for this test. I switched on the heater and observed what happened.
Without the fan running this was the result, with a target temperature of 200Deg C set in RepSnapper.
The heatsink was touch warm, but not hot which was an amazing difference in comparison to when the aluminium tube was used. With the aluminium tube you wouldn't keep your finger on the heatsink if the fan wasn't running. With the stainless tube and the fan running on the heatsink the max temperature I recorded was 178Deg C (readings from RepSnapper).

Note: I don't have any special temperature reading equipment. All the readings were taken from RepSnapper and are for relative comparison rather than specific calibrated temperature feedback purposes.

Conclusion: This was a satisfactory outcome, indicating the potential of a stainless shaft to be more effective as a structural connector between a cold-end mounted heatsink and the heater block (hot-end).

Deduction: This approach to extruder design would eliminate the need for more complex supporting side rods or PEEK T-bars. I will still entertain the idea of a PTFE liner inside the stainless tube.

Observing that some PLA that was on the nozzle had melted completely suggests to me that actual temperature on or near the nozzle may have been much hotter than my by now loosely constructed resister/thermistor arrangement was telling RepSnapper!



Photo showing melted PLA on the nozzle, after RepSnapper showed a reading of 190Deg C, an uncalibrated reading.

Thanks for viewing!

Saturday, May 14, 2011

Extruder / heater testing...the less scientific way!

Over the past few evenings I've been 'playing with' my newly assembled extruder. I've read many other blogs and studied the RepRap.org wiki, searching for extruder related posts, but there's been no substitute for trying things out myself! I suppose I could have bought more of the components and availed of the collective knowledge gathered by many, and probably been printing away by now, but for me it's also somewhat about the journey!

So... I got my heater/thermistor and stepper motor connected up, after this little interlude, and mounted the assembled unit on a bracket, not on my repstrap, and started testing. I even wired up my little fan. I started up RepSnapper and 'commanded' the heater to commence heating, 40, 50, 60... 80... 100Deg C, on it went. I got brave and punched in 180Deg C, but coax it as I might it would not heat above 140Deg C! What was wrong?

The heatsink is just too efficient it seems, and even with the fan switched off the maximum temperature I could achieve was 180Deg C. I'm sure some experts out there could have seen this coming, and probably also what happened next. Still itching to see what would happen I fed some filament into it (3mm PLA). Not satisfied with hand turning the wheel I kicked the stepper into action and in went the PLA, into the heater. I got a tiny purge of plastic from my newly drilled .4mm hole before the whole thing just stopped feeding. Reversing was also futile. There it stopped to await it's first autopsy! :-)


Reading back through some of the extruder related articles made a lot more sense now. A short as possible transition zone from hot to cool is good. See the guru Nophead's writings on the extruder subject here, and the benefit of a PTFE lining reducing upward heat migration, and smoothing the path downwards, is also manditory you'd feel if you study Adrian Bowyer's most excellent Universal Mini Extruder design. But flying in the face of the need for any PEEK or PTFE, and the long journey from feeder to heater, is the UP! Extruder design, with simple metal pipe linking 'hot-end' to 'cold-end', and not a special plastic in sight.

So where was I going wrong? Examination of the jamed extruder revealed that the idler bearing that applies pressure on the filament so it's gripped by the nobbed feeder spindle, had completely squashed the filament. See photo below.
In switching off the fan to allow the temperature to rise in the heater, the temperature also rose in the unlined feeder tube, causing the PLA filament to soften and be deformed by the idle bearing lateral pressure. The raised temperature in the feeder tube also cause the PLA to deform, expand and jam.

To remove the jammed PLA i had to heat the dismantled assembly slightly with a hot-air gun and the plastic bits pulled right out.

Determined to continue testing the hot-end I next separated it from the heatsink completely, insulated the shaft in with some glass rope and held it in a small vice. (see photo). There was no difficulty in reaching temperatures a high as 220Dec C in this situation. (12v supply to 6ohm resistor in the heater block).


While I'm not sure of the accuracy of current temperature feedback to RepSnapper I can expect it's a pretty good guideline indicator of temperature. Here's what the RepSnapper temperature control/feedback fields look like. You can also see the manual extruder speed/feed control buttons just below the temperature section. There is a 'heater on' green light also on the Gen6 board which is very handy.

And... by manually feeding some PLA I got a nice free flowing extrusion. (see photo below). It took only minimul pressure to feed the filament. The extrusion did curl as it emerged and I did have to pull it straight just to prevent it sticking to the nozzle, but over all a satisfactory result!


Conclusions:
My heatsink is too large for heat output capability of the resistor/voltage.
I either need a more powerful heater, like the UP! has... 24v 80W heat probe, or I need a better thermal barrier between the hot and cold ends of the extruder. That's back to PEEK/PTFE type design.

Some positive points... the extruder stepper, which I salvaged off and old 5.25" floppy drive, the old photocopier cog wheels, the nobbed drive shaft and the idler pressure bearing all worked very well as a feed mechanism!

Thanks for viewing... comments and questions welcome!


Wednesday, May 11, 2011

Connecting up the heater to Generation 6 electronics...

When connecting up the heater and thermistor to the Gen6 board be aware of the following... the pin-outs printed for your convenient reference right there on the board are a) technically correct, BUT b) visually misleading at the very least!
If you've already wired up your heater/thermistor you'll probably know the trap I fell into. If you haven't, and plan to using this rev or the Gen6 board, you'll get to it and then say "oh... I know what he meant now!" :-)

It's a small think, but I think worth pointing out that by reading down along the edge of the board, you would take Pin-1 to be on the left (at least I did), but see photo below, and in fairness, it is stated also on the wiki (if in a little detail well down the page), that Pin 1 is on the right as you look along the edge of the board!

Anyway, enough of the pedantics. :-) It won't cause much of a problem if you get them wrong way round. You'll put 5v through your heater, and try to heat your thermistor for a short while, then you'll figure it out... as I did.

With the heater connected up correctly I was ready to start some tests. I'll keep them to a separate post.

Thanks for viewing!

Tuesday, May 10, 2011

Extruder 'hot-end'...

I've been trying to come up with an extruder 'hot-end' design that doesn't use the expensive PEEK material that is in common use in other designs. My initial thoughts have been to use a salvaged heat-sink, clamping the feed shaft from the hot-end heater, and using a small fan to cool the heat-sink. My experiments over the last few evenings have caused me to question this approach, based on challenges I've encountered during my tests. I think I'll outline my tests in a subsequent post, but for now here are some photos and a general description of my initial hot-end design and construction.
The heatsink and aluminium blocks are all salvaged from some scrap electronics boards. I drilled a 6mm hole to receive an 6mm aluminium feeder tube. It's an 'off the shelf' piece of 6mm tube with a approx 3.5mm hole. (The thermister is not fitted in the photo above.)
I filed the top 12mm of the tube flat on three sides, and cut a square slot to match in what I'll call my clamping block. This aluminium block (salvaged heatsink block) had two convenient slots in it's sides through which I fed two small bolts in order to clamp it to the vaned heat-sink. Here's another view (below) of this assembly in which you can see one of the bolts that clamps the solid block to the vaned heatsink.

My heater is a resistor from Mendel-parts, and a matching thermistor. I secured the resister with high-temp silicone, and wrapped the thermistor in a square of plumbers PTFE tape before inserting into a 1.5mm hole, 4mm deep, a tip I gleened from Adrian's approach documented here.

Here you can see where the thermistor is secured into the block. I added some high-temp glue (used to attach glass rope to stove doors. I had a little left over from another job!). I added some glue to the resistor also. I should use that Kapton tape, but I don't have any at the moment. I think I'll have to order some other bits and pieces soon... building a new wish-list!

The nozzle is a brass cap-nut with a .4mm hole drilled in it. It took some searching but I got some .4mm drills locally (Joe McKennas, Limerick) along with a 'pin vice' from Maplin, also local. There are many great suggestions on the net on how to drill a very small hole, but you know wht worked for me? I put the cap-nut in the vice, dinged and center hole with a sharp nail, then drilled the .4mm hole by spinng the pin vice by hand while applying pressure on the bit. Brass is relatively soft and the tiny drill bit just worked right through it. ( I did try my first .4mm drill in a power drill, catching the pin vice in the power drill chuck, but the tiny bit just snapped like twig - just as well I bought a few.) You should be able to see the tiny hole in one of the photos above. Here I'm using the drill to clear the hole during first extrusion attempt.


That's if for this post. I'll do a little bit on how I got on with wiring and powering it up and some heating experiments, in the next post.

Thanks for viewing!



Monday, May 9, 2011

Extruder "cold-end"...

Here are some photos of my Extruder 'cold-end'. The motor wasn't yet secured in this shot but is now bolted to the base.
The cogs are salvaged from an old photocopier. I realise the smaller cog has typically less teeth in other designs but we'll see how this one goes! The stepper motor is from an old 5.25" floppy drive!

The bearing recesses were achieved by clamping the two 15mm blocks together and drilling a hole 22mm diameter with a flat wood bit to a dept equal to the bearing width, so the bearing would recess until flush with the edge. These recesses hold the bearing snugly in either side of the block.
Here you can see the bearing mounting block for the filament drive shaft, and it's partner, the idle pressure bearing (smaller bearing pinned into the second block.)


This photos shows the nobbed center of the shaft. I nobbed it using an M3 tap following the Wade Extruder instructions. I've used 6mm steel shaft. I cut it to the desired length and threaded both ends and am using M6 nylock nuts on either end. The skateboard bearings came with sleeves which reduce the bearing centers to 6mm, normally an 8mm hole. I'm pinning the large cog wheel with a small bolt through a hole drilled through the shaft.
Here's a photo of my extruder filament drive mechanism components.Everything has been done with minimal power tools, a variety of drill bit sizes, some files, tap and die set, saws and a bench vice. I have some photos of the 'hot-end' which I'll post next.

Thanks for viewing. Comments and questions welcome.

Wednesday, May 4, 2011

The Extruder...

I've been building my extruder for the last while. My design is mostly based on Wade's Geared Extruder, found on the RepRap.org site, but determined to remain true to my material choice I've scratch-build my extruder from mainly 15mm oak and what ever other components I could scavenge from old computer/office equipment parts and electronic boards. Here's a picture of my newly assembled extruder, without the hot-end attached.
Here's a picture of it's many constituent parts...

I've conducted basic testing of the cold-end, meaning the drive motor, linkage and filament feed mechanism. This testing was done using Repsnapper to manually control the filament feed process via the Generation 6 electronics and the results were very satisfactory. Traction was excellent. I've not plugged in the hot-end yet. A bit more assembly and wiring is needed first.

I've a lot more detail photographed and I think it deserves some further posts and descriptions, which I should get to within the next while.

Thanks for viewing.